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FontLab Studio 5 

OpenType: 
the fusion of 
design and 
technology 

OpenType technology 
has revolutionised the way 
designers work with type. 
Nick Cooke explains how 
to get maximum benefit 
from OpenType and enrich 
your creative output
 OpenType has become the new industry standard font 
format, offering countless new creative options to everyone 
working with type. Type designers have been freed from the 
shackles of PostScript’s restrictive character set, enabling them to 
include alternates, small caps, swashes, ligatures and additional 
languages within one single feature-rich (Pro) font. Furthermore, 
fonts can be ‘programmed’ to behave contextually, automatically 
inserting a stylistic alternate, ligature or end glyph into OT-savvy 
applications when the relevant feature is activated.
 In this project we look at how advanced type features 
can be programmed in FontLab Studio using G-Type’s Houschka 
Rounded font. We’ll also focus on how to make OpenType Pro fonts 
work hard for you when designing layouts in InDesign CS3. 

Designer 
Nick Cooke released 
his fi rst collection of 
typefaces under the 
G-Type banner in 
1999. He has also 
designed many 
well-known custom 
typefaces for the 
likes of Vauxhall, 
Laura Ashley and 

Skills 
  Create and 
edit glyphs
  Set up classes
  Additional 
character sets
  Use alternate 
glyphs and stylistic 
sets in InDesign
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The Mail on Sunday. 
His six-weight 
Chevin family has 
been adopted as 
Royal Mail’s 
corporate font. 
G-Type fonts are 
available from 
Fontworks UK, 
www.type.co.uk
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04  Go to Window>Panels>Classes (or click the Classes panel icon). In the Classes panel click the ‘+’ 
symbol in the bottom-left corner and select ‘New OpenType class’. On the right there are two panels. The 
bottom one will have class#: (class followed by number). Here you can type ‘a’, ‘b’, ‘c’, ‘d’, and so on, but the 
quickest way to add classes is to scroll over a to z in the font window and drag them into the top panel where 
they appear as icons, and appear as text after class1: in the bottom panel. Now scroll over class# and type ‘lc’ 
(for lower case). Select Accept. This renames the class as ‘lc’.

01  Once you’ve got a basic character set, you can start adding OpenType 
‘features’ to the font. To add a feature that replaces lower case with small caps, for 
example, go to Glyph>Generate Glyphs (Ctrl/Cmnd+G). Type upper case A to Z letters 
in the fi eld, and add the suffi x ‘small’ after each letter, separated by a space. Tick the 
Mark new glyphs box and click OK. 

02  The character boxes are 
then added to the Font window and are 
marked with a colour. Scroll over A to Z, 
copy and paste into Asmall to Zsmall. 
Uncheck ‘Keep replaced symbols under 
new names’ box, and click Replace. 
Re-colour the boxes. Then make sure 
that ‘Add all glyph classes to OpenType 
feature defi nition code’ is checked in 
Preferences>General Options>Unicode 
and OpenType. This will ensure any 
class names like ‘smcp’, ‘lc’ or ‘sc’ are 
recognised when generating an 
OpenType font.

03  There are three types of class: Kerning, Metrics and OpenType. Kerning 
and Metrics classes have a similar functionality in that they apply ‘values’ to glyphs. 
Metrics classes apply sidebearing values to glyphs – that is, the space on either side 
of a glyph. Classes work by having a ‘base’ glyph with an assigned value that other 
glyphs follow. For example, if a sidebearing or kerning value is assigned to the left side 
of a curved ‘base’ character like a lower case ‘o’, that value will be applied to other 
glyphs in the class. So the class may contain the glyphs ‘c’, ‘d’, ‘e’, ‘g’, ‘q’, and so on, as 
they have a curved left side. The class for the right side of the ‘o’ (named differently as 
‘o1’) would contain ‘b’, ‘p’, and so on. Classes are a time-saving device that apply 
changes across a range of glyphs in an instant. Lower case ‘o’ (pictured above) is the 
‘base’ character for both Metrics and Kerning classes. The left side of each glyph has 
a sidebearing value of 45. The blue colour of the glyphs following ‘o’ shows they share 
the same left-side kerning.  
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05  Now repeat the above step, but drag the small cap glyphs into the top-right panel. Scroll over 
class# and type ‘sc’. Select Accept. One of the main reasons for OpenType failure when generating the font is 
not having the same number of glyphs in each class. For replacement classes to work, the number of glyphs 
has to be equal in each class. You can see in the panel that both classes have 26 glyphs when clicking on ‘lc’ 
or ‘sc’ on the left of the Classes panel.
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07  Now you’ve created the classes you’re ready to 
create the feature that makes the small caps replace the lower 
case. Click the OT Panel icon in the menu bar and add a new 
feature by clicking the + button. Replace xxxx with smcp in both 
instances and complete the panel exactly as shown above. 

09   You may have a character in your font that has two styles. Use the Stylistic Alternates feature 
to replace one style with the other. Houschka Rounded has two styles of lower case ‘a’. The Stylistic 
Alternates feature replaces the standard lower case ‘a’ with an infant ‘a’.

10  Now we’ll show you how to create the alternate glyphs. Go to Glyph> 
Generate Glyphs (Ctrl/Cmnd+G). Type in the lower case ‘a’ plus all the accented glyphs 
in your font. Add the suffi x .salt after each. Tick the boxes shown and click OK.
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06  Now edit the small caps glyphs. Double-click on 
Asmall in the Font window to open the Glyph window. In 
Houschka Rounded the small cap is exactly the same as the 
cap ‘A’ glyph. Scroll over the small caps in the Font window to 
select them all. Go to Tools>Action>Contour>Scale. You could try 
Horizontal scale 80% and Vertical scale 75%. You then need to 
adjust the stem weights to match the lower case glyph weight: 
Tools>Action>Effects>Bold. Try ‘H’ and ‘V’ weight values of 6. 
Some cleaning up of the glyphs may be needed, and also 
re-spacing as they’ll be too tight. In the ‘before’ and ‘after’ 
characters above, I’ve pasted a lower case ‘l’ in the Mask layer 
(in green) to match the weight.

08  Click the Compile button to create the feature and 
make sure it works. Then click the Open Sample Panel button to 
view the Source and the Result when clicking the smcp button. 
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12  Now create the substitution feature. Click the OT Panel icon in the menu 
bar and add a new feature by clicking the + button. Replace xxxx with salt in both 
instances and complete the panel as shown above using the characters in your font. 

11  Double-click the a.salt glyph in the Font Window 
to open it. Delete the existing ‘a’ that has been placed there 
automatically. Design your new ‘a’. Replace the ‘a’ in the 
remaining .salt glyphs but keep the accents and reposition 
as necessary. As there are only a few glyphs in this feature, 
there’s no need to create classes, so you can go straight to 
making the feature.
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 Favourite flavour
 OpenType fonts come in two 
fl avours: PostScript (CFF outlines) or 
TrueType (TTF). Both will work perfectly 
well but, as a rough rule of thumb, 
Corporate and MS Offi ce users should 
probably veer towards TTF fl avour for 
better compatibility with PowerPoint 
in particular.

13  Click the Compile button to create the feature and make sure it works. Then click the 
Open Sample Panel button to view the Source and the Result when clicking the salt button. 14  Now use the Contextual Alternates feature to replace one style of glyph with another. 

My font Houschka Rounded has two styles of cap ‘A’ and ‘W’ and small cap ‘A’ and ‘W’. They both 
have an ‘arched’ shape. The Contextual Alternates feature replaces the standard cap ‘A’ and ‘W’ 
and small cap ‘A’ and ‘W’ with a more standard ‘A’ and ‘W’ shape. Contextual Alternates is 
constructed in exactly the same way as Stylistic Alternates except xxxx should be replaced with 
calt. As there are probably a lot more glyphs to replace, it’s a good idea to make classes like:
feature calt {
  sub @calt1 by @calt2;
} calt;
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15  I wanted to have more variety in my Houschka Rounded font, so I created 
four character sets: the standard set, a more ‘modern’ set, an Art Deco infl uenced set, 
and a Unicase set. Set creation can be quite a complex area, so it’ll take a good few 
weeks to put together. Design your character sets including all accented characters, 
small caps plus accents, and any other variations you wish to include. Generate the 
glyphs as in previous steps, but add the suffi x .1 after each glyph for the fi rst stylistic 
set, add the suffi x .2 after each glyph for the second stylistic set, and so on.

16  Now you need to create the ‘base’ class. Click the + button to add a new 
OpenType class. This will be the ‘base’ or standard class that contains the glyphs 
to be replaced by the new classes. Select and drag the glyphs into the top-right 
panel. Click the View Mode button (top right in the Classes panel), and select List. 
The ‘standard’ set, as I have named it, should include all the characters except the 
‘new’ stylistic sets. You can mark the class in colour as shown.

17  Scroll over the text in the bottom-right panel and copy it. Click the + button 
to add a new OpenType class. Paste the text into the bottom-right panel, scroll over 
‘standard’ and type ss001. Click Accept. Now you have two differently named classes 
with identical content. By doing it this way you’re ensuring there are the same number 
of glyphs in each class – 497 in this case. Now type .1 after each replacement glyph in 
the bottom right Classes panel. Click on Accept occasionally to see the replaced 
glyphs change from red to white in the top panel. 

18  Now simply follow the procedure of the previous step to create subsequent classes. Name the new 
next classes as ss002, ss003, and so on.
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19  Now create the substitution feature. Click the OT Panel icon in the menu bar and add a new feature 
by clicking the + button. Replace xxxx with ss01 in both instances and complete the panel as shown.

20  Replace xxxx with ss02 in both instances and complete the panel as shown 
above. Then replace xxxx with ss03 in both instances and complete the panel.
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21  Click the Compile button to create the features and make sure they work 
after each step. Then click the Open Sample Panel button to view the Source and the 
Result when clicking the ss01, ss02 and ss03 buttons. 

22  It’s quite important to have 
the Features in the correct order to 
ensure that they can work together. They 
can be re-ordered in the Features panel. 
You can see from the illustration that 
the features ‘kern’, ‘calt’ and the stylistic 
sets all work together. The ‘smcp’ feature 
would also work with the other features.

 Content 
 You should note that 
OpenType fonts are never equal in terms 
of content. There is no industry standard 
character set for OT Pro fonts, so be 
careful when purchasing. One Pro font 
could contain pan-European language 
coverage and multiple features; the next 
could contain a bare minimum.    
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23  Using alternate glyphs and stylistic sets in the likes of InDesign CS is very 
straightforward. With the Character Window (in the main Type menu) open, select the 
OpenType option and a submenu will appear. Features within square brackets indicate 
that they are not included in the font and are therefore unavailable for selection. Use 
this section to choose which set of fi gures you want, switch discretionary ligatures 
and contextual alternates on, select swashes, fractions, and so on. With these 
features activated, your text will alter on the fl y as you type. Alternatively, text can be 
selected when keyed in and changed later by switching features on or off. Certain 
fonts may also contain Stylistic Sets, which is a neat way of tweaking the appearance 
of your work without changing the font. 

24  Foreign language accents, or indeed any character contained in the font, 
can be accessed via the Glyph palette (Type>Glyphs). Simply double-click the glyph 
you want and it’ll appear in your document.   
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